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Data Loading 
 

 
 

Capacity Limits 
 
The maximum number of feature coordinates per feature has been increased from 40,000 to 
175,000. 
 
Improvements to Line Connectivity 
 

 Street feature connectivity has been improved.  Street features with different labels are now 
connected, and if three or more such streets share a node, the labels are checked.  For example, if 
A ST, A ST, and B ST meet, the two A STs will be connected and B ST will dangle. 

 
 The loading option Connect Lines with Different Feature Symbology now works for streets as 

well as lines.  However, the label style, box style, font parameters, and so on, must be the same 
for connection to take place. 

 
 New options 

 
• Connect Line Features with the Same Feature ID—Allows linear features to be 

connected if they have the same feature ID number. 
 

• Enable Graphical Connection—Connects all line segments with the same symbology.  
This connection only occurs when the features are viewed, and it tidies up the artwork by 
removing as many of the intersegment wedges as possible.  However, this connection is 
broken and the requested logical connection is complete when the features are submitted for 
placement. 
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Note:  When you click a line feature, the highlight depends on the state of graphical connection as 
follows: 
 

 OFF—The feature's unconnected segments are highlighted. 
 ON—The graphically connected segments are highlighted.  This may connect several 

features. 
 
It is recommended that you leave this option off during editing and turn it on for final viewing of the 
map before export. 
 
When the editor is on, clicking the label will highlight the label's connected features. 
 
Map Extents 
 
If your data is in degrees and you project it with Maplex™, you can specify your map bounds in 
latitude and longitude by clicking the new Lat/Long Extent button on the Data Manager dialog box.  
When you click the Lat/Long Extent button, a dialog box opens in which you can enter your latitude 
and longitude limits.  When you click OK, Maplex finds the smallest rectangle in map units that 
encloses those limits and uses that rectangle as the bounds, updating the Map Extent fields with the 
new values.  The dialog box accepts latitude and longitude values in decimal degrees including 
negative values. 
 
Note:  The values are not saved.  The next time you open the dialog box, the text boxes will be 
empty.  You cannot use latitude and longitude in the Batch Mode dialog box. 
 

 
 
You can also use the Full Extent and Zoom Extent options to set map bounds. 
 
Saving and Loading Projection Settings 
 
Two new buttons have been added to the Projection Parameters dialog box that allow you to save and 
load projection settings to and from a text file stored in a location you choose. 
 
You can set up a folder (perhaps shared over a network) containing all your default projections.  
When you want to use a particular projection in a dataset, open the Projection Parameters dialog box, 
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click the Load From File button, browse to the location where the file is stored, and select the file 
from the standard file browser window. 
 
Your projection settings files may or may not be complete.  For example, the values for the center of 
the projection may be missing.  You would need to fill these in (or change them if there were default 
values present) based on the extent of the map being used.  The projection is still persisted in the 
dataset as normal. 
 
Note:  The Load From File and Save To File options do not affect the map rotation and graticule 
alignment settings. 
 

 
 

Extent Filtering for ESRI Data Sources and Vector Product Format 
 
Accessing sections of large (indexed) datasets is much faster than before.  This is especially true of 
Spatial Database Engine™ (SDE®) where the filtering takes place on the server.  The filtering will 
work for data stored in both projected and geographic coordinate systems, with one exception:  If 
your data is in a geographic coordinate system and you use a projection in Maplex that has no inverse 
form, no filtering will occur. 
 
Opening a Dataset 
 
When opening a dataset, the initial folder in the file browser is now set to the project folder 
rather than the last folder opened.  This change eliminates confusion caused by switching 
between projects with similar folder structures and content. 
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Placement 
 
Street Labeling Placement 
 
This has been improved in situations where the label's height is larger than the width of the street 
feature and the label is stacked. 
 
New Parameter 
 
There is a new parameter that can be set in the rule base Align to Direction of Line.  It is located 
on the Placement tab.  It appears instead of Align to Symbol Angle if the feature class is a line and 
is designed to work with the following placement styles: 
 

 Offset Straight Left 
 Offset Straight Right 
 Offset Curved Left 
 Offset Curved Right 
 Center Straight Directed 
 Center Curved Directed 

 
For all other placement styles, the flag is unavailable.  When Align to Direction of Line is enabled, 
Maplex will always align the label to the direction of the line (the direction is determined by the 
order of the coordinates in the data) even if it means placing a label upside down.  If the placement 
style includes a left or right element, Maplex will honor it and place the label on the correct side of 
the line.  This feature allows such things as one-way arrows to be used as labels since Maplex will 
ensure the arrow always points in the correct direction.  When the parameter is off, Maplex will 
place labels in the normal way. 
 
 
Editing 
 
Saving Labels 
 
The Save Label option is now available only after placement or new edits have been made.  You 
must confirm that you want to save labels and edits if either stored labels or edits already exist on the 
disk. 
 
Restoring Labels 
 
Performing a Restore Labels operation after editing will cause your edits to be abandoned.  You 
will be prompted to confirm this action.  Existing edits are now reloaded during a Restore Labels 
operation. 
 
Editing Feedback 
 
The standard up-arrow label selection cursor gains an "F" modifier when in Follow Feature mode. 
 



Automatic Leader Lines 
 
This function can be activated by per-feature-class code.  After all labels are placed, Maplex will 
draw a line from the placed label to the feature.  The placement of the label is unaffected. 
 
Note:  Unplaced labels are unaffected. 
 
The style of the leader line will be taken from the Maplex Leader Line Properties dialog box. 
 

 
 
 
Options 
 
Inverted Label Tolerance (Tools > Options > Labeling) 
 
This is the degree to which a line or street label is allowed to exceed past the vertical and be upside 
down.  Previous versions of Maplex had this hard-coded to 5 degrees.  This parameter is global; it 
applies to all feature classes.  The angle specified on this line is validated within the range from 
0.0 through +15.0. 
 
Truncate Proper Nouns First (Tools > Options > Labeling) 
 
In previous versions of Maplex, truncation was always done to the keywords/ending part of the label 
first. 
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Example:  Original label—York Road ("Road Rd" is in the endings abbreviation file.) 
 

York Rd (abbreviated label) 
York R. 
Yor. Rd 
Yor. R. 
Yo. Rd 
Yo. R. 
Y. Rd 
Y. R. 

 
There is now an option on the Labeling tab of the Tools > Options dialog that allows the user to 
change the functionality of the truncation. 
 
Enabling the option will truncate the proper nouns in a label first. 
 
Example:  Original label—York Road ("Road Rd" is in the endings abbreviation file.) 
 

York Rd (abbreviated label) 
Yor. Rd 
Yo. Rd 
Y. Rd 
Yo. R. 
Y. R. 
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Line and Street Drawing Order (Tools > Options > Drawing) 
 
This affects linear features with the same value for their Plot Order parameter.  This setting is 
persisted in the project. 
 

 Standard drawing order—Solid lines are drawn first in the order of their appearance in the 
rule base, then cased lines are drawn in order of increasing width.  If the widths are the same, 
they are drawn in rule-based order. 
 

 Rulebase drawing order—All lines are drawn in the order of appearance in the rule base. 
 

 
 
 
Export 
 
Changes to Key Numbering 
 
In previous releases of Maplex, the key number substituted for the unplaced label was a number from 
1 to N, where N was the number of unplaced labels.  This has been extended; key numbers can now 
be generated on the following bases: 
 

 No reset—A number from 1 to N, where N is the number of unplaced labels. 
 

 Reset per grid cell—The numbers are reset to 1 in each grid cell.  The Grid Reference field 
must be included in the index export settings, which means the map must have a grid defined. 
 

 Reset per feature class code—The numbers are reset to 1 for each feature class code.  The 
Feature Class Code field must be included in the index export settings. 
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These Key Numbering options have been added to the Export Index Properties dialog box. 
 

 
 

 
 

 
 
Annotation Export 
 
Changes have been made to both the interface and the functionality of the annotation export.  
There is now an Export Annotation option in the File menu.  Selecting it opens a folder browser 
(rather than a file browser as was used previously), allowing you to choose where to save your 
annotation. 
 
If you check Create Layered Annotation, Maplex will export an annotation file (annotation 
subclass) for each unique value of the Label Layer parameter (in the Export tab), which is further 
divided into placed and unplaced text. 
 
Maplex now exports FCLASS and feature DESCRIPTION fields in both of the related files. 
 
Note:  Maplex exports two new support files in the coverage MaplexSubclassList.aml and 
MaplexHeader.aml.  They are intended to ease the burden of rendering multiple subclass 
annotation.  See the example ArcPlot.aml.mpxlayeredbuild in the utils directory. 
 
The Label Layer parameter may not be a valid subclass name.  Maplex validates each subclass name 
before using it and automatically corrects any problems.  Each of the characters in the name must be 
in one of these three sets:  [0–9] or [A–Z] or [_], and the name is limited to 13 characters.  Maplex 
will omit the illegal characters and truncate the name.  This may create unintentional duplicates.  
You can either check the log or the MaplexSubclassList.aml file for the list of subclass names used. 
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In the Annotation Settings dialog box there is an option to specify the textset file to be used.  
Checking the option Add new symbols to existing textset causes Maplex to reuse symbols in the 
textset, creating new symbols only when required.  This is useful if you are generating multiple 
annotation coverages from different maps and want to use a consistent textset. 
 
Annotation Export can now use fonts specified using the Add Fonts:  Windows Fonts option.  Care 
must be taken to ensure that the name for the TrueType or PostScript field in the font index file 
matches the name of the actual font in Windows®. 
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Automation Server 
 
The following new methods have been added to the Component Object Model (COM) interface. 
 

Name Parameters Description 
GetFeatureClasses Void GetFeatureClasses 

([out] VARIANT* numFCs, 
[out] VARIANT* FCList) 

Gets the list of Feature 
Class Codes in the current 
project. 

GetRulebaseValue Void GetRulebaseValue 
([in] BSTR code, 
[in] RulebaseFieldNameConstants 

field, 
[out] VARIANT *value) 

Gets the rule base value 
referenced by the Feature 
Class Code and the Field 
Name. 

GetRuntimeValue Void GetRuntimeValue 
([in] RuntimeParameterNameConstants 

parameterName, 
[out] VARIANT *value) 

Gets runtime parameters 
and some of the global rule
base parameters. 

SaveProjectAsXML Void SaveProjectAsXML 
([in] BSTR name) 

Saves a Maplex project 
and rule base as a named 
XML file. 

 
Example 
 
See below for Visual Basic® (VB) code illustrating this new functionality. 
 
Note:  You will need to change the home string to point to your Maplex installation folder. 
 

Private Const Home = "<Maplex35 Folder>" 
 
' The Maplex application object 
 
Dim Maplex As Maplex.Application 
Option Explicit 
Public Sub GetMaplexParameters() 
 

' Create instance of Maplex (this should start Maplex). 
 
 
' If it fails here, then Maplex is not correctly referenced.  
 
Set Maplex = CreateObject("Maplex.Application")  
Maplex.SelectProject (Home + "\Examples\Project1 ")  
Maplex.SetRulebaseValue "7822", mxSymbolWidth, "4mm" 
 

Dim value As Variant  
Dim status As Boolean 
 

' This method exports the global runtime parameters and each  
' feature class rule base parameter to an XML file. 
Maplex.SaveProjectAsXML ("c:\test.xml") 
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' Shows how to get individual rule base parameters for a given feature class code. 
Maplex.GetRulebaseValue "7822", mxFeatureClassType, value 
Debug.Print "FCType: ", value 
Maplex.GetRulebaseValue "7822", mxSymbolWidth, value 
Debug.Print "SymbolWidth: ", value 
Maplex.GetRulebaseValue "7822", mxBoxBorderColor, value 
Debug.Print "BoxBorderColour: ", value 
 
' Shows how to collect and iterate through the feature classes in a project.  
Dim numFCs As Variant 
Dim FCList As Variant 
 
Maplex.GetFeatureClasses numFCs, FCList 
Debug.Print numFCs 
Dim i As Integer 
For i = 0 To numFCs - 1 

Debug.Print i, FCList(i) 
Next i 
 

End Sub 
 
 

Others 
 
Registry Setting 
 
HideSplashScreen can be added as a string value registry key. 
 
Key location:  HKEY_LOCAL_MACHINE\SOFTWARE\ESRI\Maplex\3.5  
 
If present and set to 1, the Maplex splash screen is suppressed during startup. 
 
New Example Project 
 
<Maplex35_Folder>\Examples\RulebaseConversion project has been added. 
 
This VB project converts a stand-alone Maplex project into a Maplex for ArcGIS map document.  
The sample code supports Maplex datasets composed of shapefiles only.  Not all of the feature 
symbolization is converted; for example, dot-dash centerlines are converted to solid lines. 
 
Refer to the ArcMap™ documentation on how to add this utility as an ActiveX® control. 
 
Rule Base Converter VB Project 
 
This sample project must be compiled on a PC that has both Maplex 3.5 and ArcMap 9 Final 
installed. 
 
The sample can only be used on Maplex datasets composed entirely of shapefiles.  Datasets 
containing coverages, Vector Product Format, and so forth, are not supported. 
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To add the rule base conversion ActiveX control to ArcMap 
 

a. Select the Commands tab on the Tools > Customize dialog. 
 
b. Click Add from file... and select RulebaseConverter.dll.  
 
c. One object, CMainConverter, is added.  A Rulebase Conversion command should appear in 

the Label category. 
 
d. Drag the Rulebase Conversion icon to a toolbar. 

 
To run the tool 
 

a. Open a new map document. 
b. Set any projection required. 
c. Select the Maplex Label Engine (Labeling option on the Maplex toolbar). 
d. Click on the Rulebase Conversion icon and browse to the Maplex project folder and dataset. 

 
After the conversion process has run, the following tasks have to be done manually to complete the 
conversion: 
 

a. Set symbols for those point features originally defined by an Illustrator or computer graphics 
metafile (CGM) files in the original rule base.  These symbols all default to a crossed square 
after conversion. 

 
b. Rearrange the layers in the Table of Contents frame to restore the original plotting priorities.  

(Note:  For some layers such as streets that are rendered using cased line symbols, the 
Symbology > Advanced > Symbol Level option will have to be turned on.) 
 

c. Rearrange the labeling classes in the Label Priority Ranking dialog. 
 

d. Switch on the required layer labeling. 
 
Save Project As XML File 
 
Option added to File menu to save the current project as an XML file. 
 
The file is saved to the current project directory as "project.xml". 
 
(Note:  An XML file can be imported into an Access database.) 
 
Upgrade to MapObjects 2.3 
 
Maplex 3.5 has been upgraded to use MapObjects® 2.3.  See the ESRI Web site (www.esri.com) for 
information on the MapObjects 2.3 release. 
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New Maplex 3.5 Format 
 
All Maplex files (i.e., EDT, MPL, and UNP files) are written in Maplex 3.5 format.  
 
The Maplex 3.5 format contains one new keyword, TYPE.  It was introduced to improve the 
reloading of multilabel components and added labels. 
 
Keyword:  TYPE 
 
Format:  TYPE val1 val2 
 
Parameters: 
 
  val1—Enumerated value that indicates the label type 
 
   parent—Parent, base FC label 
   np_comp—Component label with no parent 
   comp—Component label that may or may not have a parent 
   added—Additional label added using Add Label edit operation 
 
  val2—Label FC, parents have a label FC of (null) 
 
If no TYPE line occurs in a record, it is a standard nonmultilabel. 
 
Reloading Maplex 3.4 Files 
 
MPL files are parsed to separate out their multilabel components.  These are then sorted into parent, 
parentless, and normal components.  Sometimes it is not possible to do this because the placed text 
has been changed by editing from the original label. 
 
The loading log reports the following Maplex records: 
 

a. Featureless added label records from the 3.3 prerelease—These are loaded as additional 
labels but unlinked to any feature. 

 
b. Edited multilabels—These are not loaded and the user must check/re-edit them prior to 

saving or they will be lost. 
 
On saving, the user will be informed that MPL files are going to be written in the new Maplex 3.5 
format. 
 
Registering the Maplex Type Library 
 
After installation, run the VBRegTLB.exe installer in the <installation folder>/utils directory to 
register the Maplex Type Library (MPL.TLB).  The type library can be found in <installation 
folder>/program directory. 
 
VBRegTLB.exe is a freeware utility. 
 
 


